All Mods Resource Packs Data Packs Shaders Modpacks Plugins
ProxySwitcher

ProxySwitcher

by cardinalixx • Downloads: 0 • Followers: 0
Description
Gallery
Changelog
Versions

ProxySwitcher is a client-side Fabric mod for Minecraft 1.16.5+ that adds SOCKS4 and SOCKS5 proxy support directly to the multiplayer menu.

Proxy

It adds a compact Proxy button to the server list screen, allowing you to quickly configure, test, save, and switch proxies without editing files manually.

Features

  • SOCKS4 and SOCKS5 proxy support!
  • Username/password authentication for SOCKS5
  • SOCKS4 User ID support
  • Saved proxy list
  • Quick proxy switching with double-click
  • Proxy test button
  • Smart proxy input parsing
  • Client-side only, server installation is not required

Supported proxy formats

ip:port
domain:port
ip:port:login:pass
ip:port@login:pass
login:pass@ip:port

Examples:

127.0.0.1:1080
proxy.example.com:1080
127.0.0.1:1080:user:pass
user:pass@proxy.example.com:1080

Notes

  • SOCKS4 does not use passwords, so the password field is hidden when SOCKS4 is selected.
  • The proxy test checks connection to funtime.su:25565.
  • This mod is required only on the client. Servers do not need to install it.

For questions and new mods ----> https://t.me/vibecodemods <----

How to Install ProxySwitcher (Mod)

ProxySwitcher by cardinalixx is verified for Fabric, Forge across Minecraft versions 1.16.5, 1.19.4, 1.20.1, 1.21.11, 1.21.4, 1.21.8, 26.1, 26.1.1 (latest release: 2.0.0+26.3, file size: 1.1 MB). Follow the steps below to install it safely from ModCraft.tv:

  1. Click the Download button above and select your Minecraft version (1.16.5, 1.19.4, 1.20.1, 1.21.11, 1.21.4, 1.21.8, 26.1, 26.1.1) and platform (Fabric, Forge).
  2. Make sure you have the compatible loader or environment installed for Fabric, Forge.
  3. Move the downloaded ProxySwitcher file into your Minecraft .minecraft/mods folder and launch the game.

All Versions

+ Add Version
Name Game version Platforms Published Downloads Actions
26.3
Fabric
18d ago 1
26.2
Fabric
18d ago 1
26.1.x
Fabric
18d ago 1
1.16.5
Forge
5mo ago 1
1.21.11
Fabric
5mo ago 1
1.21.8
Fabric
5mo ago 1
1.21.4
Fabric
5mo ago 1
1.20.1
Fabric
5mo ago 1
1.19.4
Fabric
5mo ago 1
1.16.5
Fabric
5mo ago 1
1.21.11
Fabric
6mo ago 1
1.16.5
Fabric
7mo ago 1
1.21.11
Fabric
7mo ago 1
1.21.8
Fabric
7mo ago 1
1.21.4
Fabric
7mo ago 1
1.20.1
Fabric
7mo ago 1
1.19.4
Fabric
7mo ago 1
1.16.5
Fabric
7mo ago 1
# 1.0.1 Fix

Fixed a crash when opening the ProxySwitcher screen on Minecraft 1.21.11.

In version 1.0.0, the 1.21.11 build manually rendered the screen background using renderBackground(...). Starting with Minecraft 1.21.11, the screen render pipeline already applies the background blur once per frame.

This caused the client to crash when pressing the ProxySwitcher button with the following error:

java.lang.IllegalStateException: Can only blur once per frame

In version 1.0.1, the ProxySwitcher screen no longer triggers the Minecraft blur pass manually. The screen now uses a safe dark overlay instead.

The screen input handling was also updated for the new Minecraft 1.21.11 mouse click API.

As a result, the ProxySwitcher menu now opens correctly on Minecraft 1.21.11 without crashing.
## 1.0.1 Fix

Fixed a startup crash on Minecraft 1.16.5.

In version 1.0.0, the 1.16.5 build was compiled for Java 8 and declared Java 8 support in fabric.mod.json, but proxymod.mixins.json still required "compatibilityLevel": "JAVA_21".

This caused Fabric Loader to fail during startup with the following error:

The requested compatibility level JAVA_21 could not be set. Level is not supported by the active JRE or ASM version.

In version 1.0.1, the Mixin compatibility level now matches the Java target of each Minecraft build:

| Minecraft version | Mixin compatibility |
| --- | --- |
| 1.16.5 | JAVA_8 |
| 1.19.4 | JAVA_17 |
| 1.20.1 | JAVA_17 |
| 1.21.x | JAVA_21 |

proxymod.mixins.json is now processed by Gradle together with fabric.mod.json, so the compatibility level is automatically expanded from the configured java_version.

As a result, the 1.16.5 build no longer incorrectly requires Java 21 and can launch correctly on Java 8+, including Java 17.

ProxySwitcher Icon
Download ProxySwitcher
Select game version
Select platform